LAMP & Ubuntu

This should be easier, but I think made harder because I corrupted my Firefox applications helper list, and then chose the wrong way out
My problem, the browser tries to download index.phtml, in retrospect because, I believe that the module wasn’t properly installed into apache. Using Ubuntu 9.04

The Right Way

This page, Apache MySQL PHP at https://help.ubuntu.com/ is the bible.

apt-get install  apache2 php5 php5-mysql libapache2-mod-php5 php5-mysql mysql-server

I am running in a virtual box so I needed to create a /etc/apache2/conf.d/fqdn. There wasn’t one on my system, it needs the line

ServerName localhost

I suspect that fixed it, and that my errors were caused by not initially correctly installing libapache2-mod-php5. I have proved that my install works by using Opera. Now to remove the .phtml line from the firefox browser and make the vm a server.


This site uses Akismet to reduce spam. Learn how your comment data is processed.

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close